Project

General

Profile

Bug #14379

Exit code 3 when running the sass compiler

Added by ArtemisHimself (Artemis Fowl) almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.4.3p205 (2017-12-14 revision 61247) [x64-mingw32]
[ruby-core:84943]

Description

Hi,
I was told by my IDE (JetBrains' WebStorm) support center to upload here a report about
a problem I'm encountering on windows 10 64bit, when launching the SASS compiler.

I installed Ruby 2.4.3-1 (x64), using the Installer.
I've installed MSYS2 64bit too, using the third option.

Here's the Ruby log:

cmd.exe /D /C call C:/Ruby24-x64/bin/scss.bat --no-cache --update fuck.scss:fuck.css
C:/Ruby24-x64/lib/ruby/gems/2.4.0/gems/sass-3.5.5/lib/sass/plugin/compiler.rb:448: [BUG] Segmentation fault
ruby 2.4.3p205 (2017-12-14 revision 61247) [x64-mingw32]

(snip)

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

Process finished with exit code 3

I see a "segmentation fault" on the top, but I don't know if that's actually relevant.

Thank you,
Artemis


Files

bug-14379.log (21 KB) bug-14379.log nobu (Nobuyoshi Nakada), 01/20/2018 12:39 PM

Related issues

Is duplicate of Ruby master - Bug #14047: SEGV happen when running script under OneDrive directory if File On-Demand is enabledClosedActions

History

Updated by ArtemisHimself (Artemis Fowl) almost 2 years ago

Edit: It shouldn't be a SASS error, as my colleague is working with the same Ruby release, SASS release, and SCSS source file

#2

Updated by nobu (Nobuyoshi Nakada) almost 2 years ago

  • Is duplicate of Bug #14047: SEGV happen when running script under OneDrive directory if File On-Demand is enabled added

Updated by nobu (Nobuyoshi Nakada) almost 2 years ago

Seems #14047.

Updated by ArtemisHimself (Artemis Fowl) almost 2 years ago

Oh, never thought about Onedrive, thank you!
Also, I apologize for the source file name, I forgot to change it, it slipped ||._.

Also available in: Atom PDF