Project

General

Profile

Bug #14911

Segmentation fault

Added by askn (Aşkın Gedik) about 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.5.0p0 (2017-12-25 revision 61468) [x86_64-darwin17]
[ruby-core:87938]

Description

Hi,
This SyntaxError

def foobar
x, 'y'
end

But this Segmentation fault

def foobar
x,nil
end

Related issues

Is duplicate of Ruby master - Bug #14261: invalid syntax segfaults: "x, true"ClosedActions

History

Updated by ned (Nedim Hadzimahmutovic) about 1 year ago

Have you tried with 2.5.1 ? It does not seg fault with 2.5.1

#2

Updated by nobu (Nobuyoshi Nakada) about 1 year ago

  • Is duplicate of Bug #14261: invalid syntax segfaults: "x, true" added
#3

Updated by nobu (Nobuyoshi Nakada) about 1 year ago

  • Status changed from Open to Rejected

Also available in: Atom PDF