Project

General

Profile

Bug #15180

Segmentation fault at 0x00000001097ffffe

Added by hdaugherty (Holden Daugherty) 11 months ago. Updated 11 months ago.

Status:
Third Party's Issue
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-darwin17]
[ruby-core:89221]

Description

I have an alias called brewitup in my .zshrc that runs

brew update; brew upgrade; brew prune; brew cleanup; brew doctor

When I ran this it got hung up and gave me the error:

/usr/local/Homebrew/Library/Homebrew/cache_store.rb:31: [BUG] Segmentation fault at 0x00000001097ffffe

I have never put in a bug before so I tried to gather as much information as I could; I attached the command output and the crash report.


Files

brewitup-error-output.txt (47.9 KB) brewitup-error-output.txt Command Output hdaugherty (Holden Daugherty), 09/30/2018 04:46 PM
ruby_2018-09-30-122450_Holdens-MacBook-Air-7.crash (73.4 KB) ruby_2018-09-30-122450_Holdens-MacBook-Air-7.crash Crash Report hdaugherty (Holden Daugherty), 09/30/2018 04:49 PM

Related issues

Is duplicate of Ruby master - Bug #15137: Can't run brew cleanupThird Party's IssueActions

History

#1

Updated by nobu (Nobuyoshi Nakada) 11 months ago

  • Is duplicate of Bug #15137: Can't run brew cleanup added
#2

Updated by nobu (Nobuyoshi Nakada) 11 months ago

  • Status changed from Open to Third Party's Issue

I can't reproduce it on linkage.db files uploaded there, but dbm_open in the system library returns NULL instead.
I guess the system bundled dbm has a incompatibility or a bug which causes the failure or the segfaults, and we can't manage that library.

Also available in: Atom PDF