Project

General

Profile

Actions

Bug #16198

closed

Packaging regression in ruby-2.4.8

Added by qyliss (Alyssa Ross) over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
2.4.8
[ruby-core:95187]

Description

In the ruby-2.4.8 tarball, the ruby-2.4.8/gems directory does not
contain the extracted default gems. This is a change from 2.4.7, and is
also not the case in 2.5.7. I would not expect this to change for a
teeny release, and suspect it was a packaging error.

Compare the output of tar tf ruby-2.4.8.tar.gz ruby-2.4.8/gems with
tar tf ruby-2.4.7.tar.gz ruby-2.4.7/gems and you'll see what I mean.

This broke our packaging scripts in Nixpkgs, and I suspect it will
affect other packagers as well.


Related issues

Is duplicate of Ruby master - Bug #16197: make install under non-root user fails for Ruby 2.4.8 tarball ClosedActions

Updated by qyliss (Alyssa Ross) over 1 year ago

This can be closed — I see now that it’s a duplicate.

Actions #2

Updated by znz (Kazuhiro NISHIYAMA) over 1 year ago

  • Is duplicate of Bug #16197: make install under non-root user fails for Ruby 2.4.8 tarball added
Actions #3

Updated by znz (Kazuhiro NISHIYAMA) over 1 year ago

  • Status changed from Open to Closed
Actions

Also available in: Atom PDF