Project

General

Profile

Bug #16197

make install under non-root user fails for Ruby 2.4.8 tarball

Added by sorah (Sorah Fukumori) 2 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:95181]

Description

http://www.ruby-lang.org/en/news/2019/10/01/ruby-2-4-8-released/

Ruby 2.4.8 tarball doesn't install under non-root user with the following error:

installing bundle gems:       /usr/share/rbenv/versions/2.4.8/lib/ruby/gems/2.4.0 (build_info, cache, doc, extensions, gems, specifications)
/usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package.rb:383:in `initialize': Permission denied @ rb_sysopen - /usr/share/rbenv/versions/2.4.8/lib/ruby/gems/2.4.0/gems/did_you_mean-1.1.0/.gitignore (Errno::EACCES)
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package.rb:383:in `open'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package.rb:383:in `block (2 levels) in extract_tar_gz'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package/tar_reader.rb:65:in `each'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package.rb:365:in `block in extract_tar_gz'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package.rb:492:in `block in open_tar_gz'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package.rb:489:in `wrap'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package.rb:489:in `open_tar_gz'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package.rb:364:in `extract_tar_gz'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package.rb:345:in `block (2 levels) in extract_files'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package/tar_reader.rb:65:in `each'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package.rb:342:in `block in extract_files'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package/file_source.rb:30:in `open'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package/file_source.rb:30:in `with_read_io'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/package.rb:339:in `extract_files'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/installer.rb:801:in `extract_files'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/installer.rb:302:in `install'
        from ./tool/rbinstall.rb:685:in `call'
        from ./tool/rbinstall.rb:685:in `block in <class:Installer>'
        from ./tool/rbinstall.rb:784:in `block (3 levels) in <main>'
        from /usr/share/rbenv/sources/2.4.8/ruby-2.4.8/lib/rubygems/user_interaction.rb:51:in `use_ui'
        from ./tool/rbinstall.rb:784:in `block (2 levels) in <main>'
        from ./tool/rbinstall.rb:780:in `each'
        from ./tool/rbinstall.rb:780:in `block in <main>'
        from ./tool/rbinstall.rb:822:in `block in <main>'
        from ./tool/rbinstall.rb:819:in `each'
        from ./tool/rbinstall.rb:819:in `<main>'
make: *** [uncommon.mk:284: do-install-nodoc] Error 1

Release maintainers are aware of this issue and give a follow up soon.
Opening this ticket for tracking the issue. I will post an update on www.ruby-lang.org.


Related issues

Has duplicate Ruby master - Bug #16198: Packaging regression in ruby-2.4.8ClosedActions

History

Updated by mame (Yusuke Endoh) 2 months ago

  • Status changed from Open to Closed

We've released 2.4.9.

https://www.ruby-lang.org/en/news/2019/10/02/ruby-2-4-9-released/

Sorry for your inconvenience.

#3

Updated by znz (Kazuhiro NISHIYAMA) 2 months ago

  • Has duplicate Bug #16198: Packaging regression in ruby-2.4.8 added

Also available in: Atom PDF