Project

General

Profile

Bug #16362

Unable to build Ruby 2.6.5 on Manjaro Linux 18.1.3

Added by Marzipanzerfaust (Jeffrey Crochet) 14 days ago. Updated 14 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
2.6.5
[ruby-core:95912]

Description

Steps to reproduce:

$ curl -OL https://cache.ruby-lang.org/pub/ruby/2.6/ruby-2.6.5.tar.gz
$ tar xvf ruby-2.6.5.tar.gz
$ cd ruby-2.6.5
$ ./configure
$ make

./configure summary:

   * Installation prefix: /usr/local
   * exec prefix:         ${prefix}
   * arch:                x86_64-linux
   * site arch:           ${arch}
   * RUBY_BASE_NAME:      ruby
   * ruby lib prefix:     ${libdir}/${RUBY_BASE_NAME}
   * site libraries path: ${rubylibprefix}/${sitearch}
   * vendor path:         ${rubylibprefix}/vendor_ruby
   * target OS:           linux
   * compiler:            gcc
   * with pthread:        yes
   * enable shared libs:  no
   * dynamic library ext: so
   * CFLAGS:              ${optflags} ${debugflags} ${warnflags}
   * LDFLAGS:             -L. -fstack-protector-strong -rdynamic \
                          -Wl,-export-dynamic
   * DLDFLAGS:            -Wl,--compress-debug-sections=zlib
   * optflags:            -O3
   * debugflags:          -ggdb3
   * warnflags:           -Wall -Wextra -Wdeclaration-after-statement \
                          -Wdeprecated-declarations -Wduplicated-cond \
                          -Wimplicit-function-declaration -Wimplicit-int \
                          -Wmisleading-indentation -Wpointer-arith \
                          -Wrestrict -Wwrite-strings \
                          -Wimplicit-fallthrough=0 -Wmissing-noreturn \
                          -Wno-cast-function-type \
                          -Wno-constant-logical-operand -Wno-long-long \
                          -Wno-missing-field-initializers \
                          -Wno-overlength-strings \
                          -Wno-packed-bitfield-compat \
                          -Wno-parentheses-equality -Wno-self-assign \
                          -Wno-tautological-compare -Wno-unused-parameter \
                          -Wno-unused-value -Wsuggest-attribute=format \
                          -Wsuggest-attribute=noreturn -Wunused-variable
   * strip command:       strip -S -x
   * install doc:         yes
   * JIT support:         yes
   * man page type:       doc

make failed with the following output:

        BASERUBY = /usr/bin/ruby --disable=gems
        CC = gcc
        LD = ld
        LDSHARED = gcc -shared
        CFLAGS = -Wall -Wextra -Werror -Wfatal-errors -Wshadow -Wdouble-promotion -Wformat=2   -Wformat-truncation -Wundef -fno-common -Wconversion -Os 
        XCFLAGS = -D_FORTIFY_SOURCE=2 -fstack-protector-strong -fno-strict-overflow -fvisibility=hidden -fexcess-precision=standard -DRUBY_EXPORT -fPIE -DCANONICALIZATION_FOR_MATHN
        CPPFLAGS =   -I. -I.ext/include/x86_64-linux -I./include -I. -I./enc/unicode/12.1.0 
        DLDFLAGS = -Wl,--compress-debug-sections=zlib -fstack-protector-strong -pie  
        SOLIBS = -lz -lpthread -lrt -lrt -lgmp -ldl -lcrypt -lm 
        LANG = en_US.UTF-8
        LC_ALL = 
        LC_CTYPE = 
gcc (GCC) 9.2.0
Copyright (C) 2019 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

compiling ./main.c
In file included from ./include/ruby.h:33,
                 from ./main.c:13:
./include/ruby/ruby.h: In function ‘rb_array_ptr_use_end’:
./include/ruby/ruby.h:2186:35: error: unused parameter ‘allow_transient’ [-Werror=unused-parameter]
 2186 | rb_array_ptr_use_end(VALUE a, int allow_transient)
      |                               ~~~~^~~~~~~~~~~~~~~
compilation terminated due to -Wfatal-errors.
cc1: all warnings being treated as errors
make: *** [uncommon.mk:1069: main.o] Error 1

Just to be sure, I also attempted this with GCC versions 8.3.0 and 7.5.0, both of which produced the same error.


Related issues

Related to Ruby master - Feature #15665: Cannot compile socket extension on MojaveClosedActions

History

Updated by Marzipanzerfaust (Jeffrey Crochet) 14 days ago

Sorry, I discovered that something was resetting my CFLAGS. Please close this.

#2

Updated by mame (Yusuke Endoh) 14 days ago

  • Related to Feature #15665: Cannot compile socket extension on Mojave added

Updated by mame (Yusuke Endoh) 14 days ago

  • Status changed from Open to Closed

Closing as per OP's request. Thanks.

Also available in: Atom PDF