Project

General

Profile

Actions

Bug #18503

closed

Make ruby-2.7.5 on Solaris 10 openssl: Could not be configured. It will not be installed.

Added by dklein (Dmitri Klein) 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:107213]

Description

openssl:
Could not be configured. It will not be installed.
/export0/home/telegraf/fluentd/ruby_versions/ruby275/ruby-2.7.5/ext/openssl/extconf.rb:111: OpenSSL >= 1.0.1, < 3.0.0 or LibreSSL >= 2.5.0 is required
Check ext/openssl/mkmf.log for more details.

Meanwhile..

which openssl

/opt/csw/bin/amd64/openssl

/opt/csw/bin/amd64/openssl version

OpenSSL 1.0.2u 20 Dec 2019

Updated by dklein (Dmitri Klein) 4 months ago

Adding --with-openssl-dir

CC=/usr/sfw/bin/gcc CFLAGS="-std=gnu99" ./configure --with-openssl-dir=/opt/csw/bin/amd64

didn't help:


checking for OpenSSL version >= 1.0.1 and < 3.0.0... -------------------- no

"/usr/sfw/bin/gcc -I../../.ext/include/i386-solaris2.10 -I../.././include -I../.././ext/openssl -I/usr/sfw/include -I/opt/csw
/bin/amd64/include -std=gnu99 -D_XOPEN_SOURCE=600 -D_LARGEFILE_SOURCE=1 -D_FILE_OFFSET_BITS=64 -std=gnu99 -c conftest.c"
conftest.c:6: error: size of array `conftest_const' is negative
checked program was:
/* begin /
1: #include "ruby.h"
2:
3: #include <openssl/opensslv.h>
4:
5: /top/
6: int conftest_const[(OPENSSL_VERSION_NUMBER >= 0x10001000L) ? 1 : -1];
/
end */


Updated by hsbt (Hiroshi SHIBATA) 4 months ago

  • Status changed from Open to Closed
Actions

Also available in: Atom PDF