Project

General

Profile

Bug #2670

Net::IMAP parser problem

Added by mithrandi (Tristan Seligmann) over 9 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
ruby -v:
ruby 1.9.1p378 (2010-01-10 revision 26273) [x86_64-linux]
[ruby-core:27913]

Description

=begin
Using Net::IMAP against Dovecot (1.2.10) results in problems when switching between folders:

C: RUBY0003 SELECT sf-linkreq
S: * OK [CLOSED] Previous mailbox closed.
@str: "* OK [CLOSED] Previous mailbox closed.\r\n"
@pos: 13
@lex_state: EXPR_BEG
@token.symbol: RBRA
@token.value: "]"
/usr/lib/ruby/1.9.1/net/imap.rb:3136:in `parse_error': unexpected token RBRA (expected SPACE) (Net::IMAP::ResponseParseError)

This problem does not occur with Ruby 1.8:

C: RUBY0003 SELECT sf-linkreq
S: * OK [CLOSED] Previous mailbox closed.
S: * FLAGS (\Answered \Flagged \Deleted \Seen \Draft)
S: * OK [PERMANENTFLAGS (\Answered \Flagged \Deleted \Seen \Draft *)] Flags permitted.
S: * 48 EXISTS
S: * 0 RECENT
S: * OK [UIDVALIDITY 1264626539] UIDs valid
S: * OK [UIDNEXT 49] Predicted next UID
S: * OK [HIGHESTMODSEQ 1] Highest
S: RUBY0003 OK [READ-WRITE] Select completed.
=end

History

#1

Updated by shugo (Shugo Maeda) over 9 years ago

  • Assignee set to shugo (Shugo Maeda)

=begin

=end

#2

Updated by shugo (Shugo Maeda) over 9 years ago

=begin
It seems that the bug has already been fixed in svn trunk.
Could you try svn trunk?
=end

#3

Updated by mithrandi (Tristan Seligmann) over 9 years ago

=begin
I've tested this with "ruby 1.9.2dev (2010-02-03 trunk 26544) [x86_64-linux]" and it seems to be working now; sorry for the noise!

=end

#4

Updated by rgrove (Ryan Grove) over 9 years ago

=begin
I've reproduced this in ruby 1.8.7 (2008-08-11 patchlevel 72) [universal-darwin10.0], and a user reports that he also sees the issue in ruby 1.8.6 (2008-08-11 patchlevel 287) [i386-mswin32], so it seems like 1.8 is indeed affected.
=end

#5

Updated by shugo (Shugo Maeda) over 9 years ago

  • Status changed from Open to Closed

=begin
It seems that the fix has been already backported into the ruby_1_8_7 branch.
If you would like to see the fix in the ruby_1_8_6 branch, please create a ticket in the Ruby 1.8.6 project.
=end

Also available in: Atom PDF