Bug #3053

Psych should not be installed without libyaml.

Added by Takashi Tamura over 5 years ago. Updated over 4 years ago.

ruby -v:ruby 1.9.2dev (2010-03-30 trunk 27101) [x86_64-darwin10.3.0] Backport:


At trunk, psych is installed even if the system does not have libyaml.
If psych continues to require libyaml, I think lib/psych should move to
ext/psych/lib/psych, like ext/openssl/lib/openssl and ext/digest/lib/digest.


Related issues

Related to Ruby trunk - Bug #3054: test/psych is executed without libyaml Closed 03/30/2010


#1 Updated by Nobuyoshi Nakada over 5 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r27112.
Takashi, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


Also available in: Atom PDF