Project

General

Profile

Bug #3083

Regression in 1.9.2 splat handling?

Added by ernie (Ernie Miller) over 9 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 1.9.2dev (2010-04-02 trunk 27190) [x86_64-darwin10.3.0]
Backport:
[ruby-core:29230]

Description

=begin
It appears as though the handling of splats has reverted back to the 1.8.7 way of doing things sometime between 1.9.1 and now. Was this documented somewhere, or is it a bug? In 1.9.1...

Neo:meta_search emiller$ ruby -v
ruby 1.9.1p378 (2010-01-10 revision 26273) [i386-darwin10.2.0]
Neo:meta_search emiller$ irb
ruby-1.9.1-p378 > a = [1,2,3]
=> [1, 2, 3]
ruby-1.9.1-p378 > puts *a, "and some more"
1
2
3
and some more
=> nil
ruby-1.9.1-p378 >

In 1.9.2-head...

Neo:meta_search emiller$ ruby -v
ruby 1.9.2dev (2010-04-02 trunk 27190) [x86_64-darwin10.3.0]
Neo:meta_search emiller$ irb

a = [1,2,3]
=> [1, 2, 3]
puts *a, "and some more"
SyntaxError: compile error
(irb):2: syntax error, unexpected tSTRING_BEG, expecting tAMPER
puts *a, "and some more"
^
from (irb):2

=end

History

#1

Updated by ernie (Ernie Miller) over 9 years ago

=begin
Looks like it's working now. Don't see any changes to the source that should have affected it so I'm going to assume it was an RVM glitch on my end. Please close this ticket. Thanks!
=end

#2

Updated by nobu (Nobuyoshi Nakada) over 9 years ago

  • Status changed from Open to Rejected

=begin

=end

Also available in: Atom PDF