Project

General

Profile

Bug #3254

[BUG] Segmentation fault

Added by DBA (Diogo Almeida) almost 10 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
1.9.2dev
Backport:
[ruby-core:30068]

Description

=begin
Per message suggestion, reporting a possible segmentation fault bug while yielding a block within mediainfo gem.

/Users/dba/.rvm/gems/ruby-head/gems/mediainfo-0.7.1/lib/mediainfo/attr_readers.rb:36: [BUG] Segmentation fault
ruby 1.9.2dev (2010-05-04 trunk 27615) [x86_64-darwin10.3.0]

-- control frame ----------
c:0014 p:0067 s:0047 b:0046 l:000430 d:000045 LAMBDA /Users/dba/.rvm/gems/ruby-head/gems/mediainfo-0.7.1/lib/mediainfo/attr_readers.rb:36
c:0013 p:---- s:0043 b:0043 l:000042 d:000042 FINISH
c:0012 p:0075 s:0041 b:0041 l:000c28 d:000c28 METHOD /Users/dba/.rvm/gems/ruby-head/gems/mediainfo-0.7.1/lib/mediainfo.rb:143
c:0011 p:---- s:0034 b:0034 l:000033 d:000033 FINISH
c:0010 p:0255 s:0032 b:0031 l:000d90 d:000d90 METHOD /Users/dba/work/mobbit/insight.v3/programming/content_upload_daemon/lib/insight_v3/video.rb:56
c:0009 p:0011 s:0025 b:0025 l:000024 d:000024 METHOD /Users/dba/work/mobbit/insight.v3/programming/content_upload_daemon/lib/insight_v3/video.rb:21
c:0008 p:0042 s:0021 b:0021 l:000020 d:000020 METHOD /Users/dba/work/mobbit/insight.v3/programming/content_upload_daemon/lib/insight_v3/upload_processor/file_processor.rb:11
c:0007 p:0088 s:0017 b:0017 l:000016 d:000016 METHOD /Users/dba/work/mobbit/insight.v3/programming/content_upload_daemon/lib/insight_v3/upload_processor/daemon.rb:24
c:0006 p:0027 s:0013 b:0013 l:001498 d:000012 BLOCK ./bin/content_upload_daemon:22
c:0005 p:---- s:0011 b:0011 l:000010 d:000010 FINISH
c:0004 p:---- s:0009 b:0009 l:000008 d:000008 CFUNC :loop
c:0003 p:0206 s:0006 b:0006 l:001498 d:000a48 EVAL ./bin/content_upload_daemon:21
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:001498 d:001498 TOP


-- Ruby level backtrace information ----------------------------------------
./bin/content_upload_daemon:21:in <main>'
./bin/content_upload_daemon:21:in
loop'
./bin/content_upload_daemon:22:in block in <main>'
/Users/dba/work/mobbit/insight.v3/programming/content_upload_daemon/lib/insight_v3/upload_processor/daemon.rb:24:in
start'
/Users/dba/work/mobbit/insight.v3/programming/content_upload_daemon/lib/insight_v3/upload_processor/file_processor.rb:11:in process_product_file'
/Users/dba/work/mobbit/insight.v3/programming/content_upload_daemon/lib/insight_v3/video.rb:21:in
create_sample!'
/Users/dba/work/mobbit/insight.v3/programming/content_upload_daemon/lib/insight_v3/video.rb:56:in inspect_video'
/Users/dba/.rvm/gems/ruby-head/gems/mediainfo-0.7.1/lib/mediainfo.rb:143:in
method_missing'
/Users/dba/.rvm/gems/ruby-head/gems/mediainfo-0.7.1/lib/mediainfo/attr_readers.rb:36:in `block in mediainfo_attr_reader'

-- C level backtrace information -------------------------------------------

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

Abort trap

Please let me know if further information is required.
=end


Related issues

Is duplicate of Ruby master - Bug #3250: [BUG] Segmentation faultClosed05/05/2010mame (Yusuke Endoh)Actions
#1

Updated by DBA (Diogo Almeida) almost 10 years ago

=begin
Duplication of #3250. My bad.
=end

#2

Updated by mame (Yusuke Endoh) almost 10 years ago

  • Status changed from Open to Closed

=begin
This issue was solved with changeset r27703.
Diogo, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.

=end

Also available in: Atom PDF