Project

General

Profile

Bug #3623

TypeError: can't iterate from Time

Added by sheuer (Stephen Heuer) over 9 years ago. Updated almost 9 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby 1.9.2dev (2010-07-15 revision 28653) [x86_64-darwin10.4.0]
Backport:
[ruby-core:31521]

Description

=begin
ruby-1.9.2-head > (Time.now..Time.now + 100).include?(Time.now + 10)
TypeError: can't iterate from Time
from (irb):1:in each'
from (irb):1:in
include?'
from (irb):1:in include?'
from (irb):1
from /Users/sheuer/.rvm/rubies/ruby-1.9.2-head/bin/irb:17:in
'
=end

#1

Updated by nobu (Nobuyoshi Nakada) over 9 years ago

  • Status changed from Open to Rejected

=begin
Intended behavior.
Instead, cover? should work.
=end

Also available in: Atom PDF