Bug #4439

TestBeginEndBlock#test_should_propagate_signaled が必ず1度失敗する

Added by Motohiro KOSAKI about 3 years ago. Updated about 1 year ago.

[ruby-dev:43270]
Status:Closed
Priority:Low
Assignee:Shota Fukumori
Category:test
Target version:2.0.0
ruby -v:ruby 2.0.0dev (2013-02-17 trunk 39291) [x86_64-darwin12.2.0] Backport:

Description

=begin
% make test-all TESTS="-v test/ruby/test_beginendblock.rb -j2"

のように、test_beginendblock.rbを並列実行すると


Running tests:

TestBeginEndBlock#testbeginendblock = 0.17 s = .
TestBeginEndBlock#test
begininclass = 0.00 s = .
TestBeginEndBlock#testbegininmethod = 0.00 s = .
TestBeginEndBlock#test
endblockraise = 0.21 s = .
TestBeginEndBlock#test
endblockwarn = 0.07 s = .
TestBeginEndBlock#testnestedatexit = 0.03 s = .
TestBeginEndBlock#test
raiseinatexit = 0.03 s = .
TestBeginEndBlock#test
shouldpropagateexitcode = 0.03 s = .
TestBeginEndBlock#test
shouldpropagatesignaled = 5.03 s = F

Retrying...

TestBeginEndBlock#testbeginendblock = 0.13 s = .
TestBeginEndBlock#test
begininclass = 0.00 s = .
TestBeginEndBlock#testbegininmethod = 0.00 s = .
TestBeginEndBlock#test
endblockraise = 0.20 s = .
TestBeginEndBlock#test
endblockwarn = 0.07 s = .
TestBeginEndBlock#testnestedatexit = 0.03 s = .
TestBeginEndBlock#test
raiseinatexit = 0.03 s = .
TestBeginEndBlock#test
shouldpropagateexitcode = 0.03 s = .
TestBeginEndBlock#test
shouldpropagatesignaled = 0.14 s = .

Finished tests in 6.488242s, 1.3871 tests/s, 2.9284 assertions/s.

9 tests, 19 assertions, 0 failures, 0 errors, 0 skips

のように testshouldpropagate_signaled が必ず1度失敗してから
リトライで成功します。

=end

History

#1 Updated by Shota Fukumori about 1 year ago

  • Description updated (diff)
  • Status changed from Assigned to Feedback
  • ruby -v changed from ruby 1.9.3dev (2011-02-24 trunk 30951) [x86_64-linux] to ruby 2.0.0dev (2013-02-17 trunk 39291) [x86_64-darwin12.2.0]

=begin
Can't reproduce on OS X 10.8 with both ruby20_0 and trunk:

  • ruby 2.0.0dev (2013-02-17 trunk 39291) [x86_64-darwin12.2.0]
  • ruby 2.0.0dev (2013-02-16 trunk 39280) [x86_64-darwin12.2.0]

Maybe able to reproduce on Linux?
=end

#2 Updated by Shota Fukumori about 1 year ago

Also can't reproduce at "ruby 1.9.3p362 (2012-12-25 revision 38607) [x86_64-darwin12.2.0]"

#3 Updated by Shota Fukumori about 1 year ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF