Project

General

Profile

Actions

Bug #4478

closed

hash order preservation fails on 64bit machine

Added by JWuttke (Joachim Wuttke) over 10 years ago. Updated over 10 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
1.9.0
Backport:
[ruby-core:35447]

Description

=begin
On a 32bit machine:

~$ uname -r
2.6.32-5-686
~$ ruby1.9 -e "x={};x[:a]=1;x[:b]=2;p x"
{:a=>1, :b=>2} # as it should

On a 64bit machine:
~$ uname -r
2.6.24-etchnhalf.1-amd64
~$ ruby1.9 -e "x={};x[:a]=1;x[:b]=2;p x"
{:b=>2, :a=>1} # failure

=end

Updated by naruse (Yui NARUSE) over 10 years ago

  • Status changed from Open to Feedback

=begin
I can't reproduce this.
Can you show ruby -v ?
=end

Actions #2

Updated by JWuttke (Joachim Wuttke) over 10 years ago

=begin
~$ ruby1.9 -v
ruby 1.9.0 (2006-06-08) [x86_64-linux]

=end

Updated by naruse (Yui NARUSE) over 10 years ago

  • Status changed from Feedback to Rejected

1.9.0 is too old (and this is pre released one) and obsoleted.
Please reopen this if it still happens on the latest version of ruby.

Actions

Also available in: Atom PDF