Project

General

Profile

Backport #5629

Windows環境で日本語を含むパスに対して、File.expand_path が存在しないパスを返すパターンが存在する。

Added by hannibal (Masafumi Kiribayashi) almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-dev:44864]

Description

Windows環境の1.9.3-p0において、(http://rubyinstaller.org/のバイナリでテスト)
path1 = "H:/TEMP/いろは/file"
というファイルが存在したとして、
path2 = File.expand_path(path1)
とすると、
path1 == path2 => true
File.exist?(path1) => true
File.exist?(path2) => false
となります。
1.8.7-p352、1.9.2-p290では、すべてtrueとなります。
日本語名のディレクトリを途中に挟む場合に発生します。


Files

test.rb (243 Bytes) test.rb hannibal (Masafumi Kiribayashi), 11/14/2011 01:27 PM

Related issues

Is duplicate of Backport193 - Backport #5601: Ruby 1.9.3 fails to compile in directories with accent in their namesClosed11/09/2011Actions

Associated revisions

Revision 3f8c4ba7
Added by usa (Usaku NAKAMURA) over 7 years ago

merge revision(s) 33603:

  • file.c (file_expand_path): reset coderange after expanding path.

[Backport #5601] [Backport #5629]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_3@34435 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 34435
Added by usa (Usaku NAKAMURA) over 7 years ago

merge revision(s) 33603:

  • file.c (file_expand_path): reset coderange after expanding path.

[Backport #5601] [Backport #5629]

History

Updated by usa (Usaku NAKAMURA) over 7 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF