Project

General

Profile

Bug #5860

Hash literal '{:a==>1}'

Added by hasari (Hiro Asari) about 7 years ago. Updated about 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.0.0dev (2011-12-31 trunk 34165) [x86_64-darwin11.2.0]
Backport:
[ruby-core:41963]

Description

=begin
There is an esoteric hash literal construct possible in the Ruby grammar:

{:a==>1}

Looking at (()), I am pretty sure this is intended behavior, but I wanted to make sure that this is so.

=end

History

Updated by naruse (Yui NARUSE) about 7 years ago

  • Status changed from Open to Rejected

Well trained rubyist will see a setter-like property symbol :a=.

Also available in: Atom PDF