Project

General

Profile

Actions

Bug #6685

closed

duplicate results in Dir[]

Added by john_firebaugh (John Firebaugh) over 10 years ago. Updated over 10 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 1.9.3p194 (2012-04-20 revision 35410) [x86_64-darwin11.3.0]
Backport:
[ruby-core:46095]

Description

$ mkdir a
$ touch a/b.rb
$ irb

Dir['a{,/**}/*.rb']
=> ["a/b.rb", "a/b.rb"]

I expected ["a/b.rb"].

Updated by john_firebaugh (John Firebaugh) over 10 years ago

Hmm, according to http://www.ruby-forum.com/topic/153846 this is intended behavior.

Updated by nobu (Nobuyoshi Nakada) over 10 years ago

  • Status changed from Open to Rejected

Yes, it's expected.

Actions

Also available in: Atom PDF

Like0
Like0Like0