Project

General

Profile

Actions

Bug #7164

closed

no such file to load -- timecop

Added by arbi.bensassi (Arbi Ben Sassi) about 9 years ago. Updated about 9 years ago.

Status:
Third Party's Issue
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby 1.8.7 (2010-06-23 patchlevel 299) [x86_64-linux]
[ruby-core:48001]

Description

=begin
When I upgrade redmine from 1.2.1 to 2.1.2 when i trying to migrate plugins i have this error every time i execute a rake command.

Please any idea about this error ?

rake --trace
rake aborted!
no such file to load -- timecop
/home/formation1/redmine-2.1/plugins/redmine_backlogs/lib/tasks/test.rake:5:in require'
/home/formation1/redmine-2.1/plugins/redmine_backlogs/lib/tasks/test.rake:5
/home/formation1/redmine-2.1/lib/tasks/redmine.rake:121:in
load'
/home/formation1/redmine-2.1/lib/tasks/redmine.rake:121
/home/formation1/redmine-2.1/lib/tasks/redmine.rake:121:in each'
/home/formation1/redmine-2.1/lib/tasks/redmine.rake:121
/usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/engine.rb:425:in
load'
/usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/engine.rb:425:in load_tasks'
/usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/engine.rb:425:in
each'
/usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/engine.rb:425:in load_tasks'
/usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/application.rb:145:in
load_tasks'
/usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/railtie/configurable.rb:30:in send'
/usr/lib/ruby/gems/1.8/gems/railties-3.2.8/lib/rails/railtie/configurable.rb:30:in
method_missing'
/home/formation1/redmine-2.1/Rakefile:7
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/rake_module.rb:25:in load'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/rake_module.rb:25:in
load_rakefile'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:501:in raw_load_rakefile'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:82:in
load_rakefile'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:133:in standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:81:in
load_rakefile'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:65:in run'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:133:in
standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/lib/rake/application.rb:63:in run'
/usr/lib/ruby/gems/1.8/gems/rake-0.9.2.2/bin/rake:33
/usr/bin/rake:23:in
load'
/usr/bin/rake:23
=end

Updated by sorah (Sorah Fukumori) about 9 years ago

  • Status changed from Open to Rejected
  • Priority changed from 6 to 3

Rejecting because here is Ruby's bug tracker, not of Redmine's.

and I guess your problem is not a bug of Redmine, I recommend to ask at ruby-talk or somewhere.

Thank you.

Actions #2

Updated by shyouhei (Shyouhei Urabe) about 9 years ago

  • Status changed from Rejected to Third Party's Issue
Actions

Also available in: Atom PDF