Bug #7413

make check returns weird error code

Added by Vit Ondruch over 1 year ago. Updated over 1 year ago.

[ruby-core:49767]
Status:Rejected
Priority:Normal
Assignee:-
Category:-
Target version:-
ruby -v:ruby 2.0.0dev (2012-11-19 trunk 37735) [x86_64-linux] Backport:

Description

=begin
The return code should be 0 IMO, since there seems to be nothing wrong, but it is not:

$ make check 'TESTS=-v -x testm17ncomb.rb -x testrakefunctional.rb'
CC = gcc
LD = ld
LDSHARED = gcc -shared
CFLAGS = -O2 -g -pipe -Wall -Wp,-DFORTIFYSOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -mtune=generic -fPIC -m64
XCFLAGS = -include ruby/config.h -include ruby/missing.h -DFORTIFYSOURCE=2 -fstack-protector -fno-strict-overflow -fvisibility=hidden -DRUBYEXPORT
CPPFLAGS = -I. -I.ext/include/x86
64-linux -I./include -I.
DLDFLAGS = -Wl,-soname,libruby.so.2.0 -fstack-protector -m64
SOLIBS = -lpthread -lrt -ldl -lcrypt -lm

generating encdb.h

... snip ...

XpathTestCase#testancestors = 0.00 s = .
XpathTestCase#test
commentinxpathquery = 0.00 s = .
XpathTestCase#test
parentage = 0.00 s = .
XpathTestCase#testtextaselement = 0.00 s = .
XpathTestCase#test
textinxpath_query = 0.00 s = .

Finished tests in 370.232067s, 30.7564 tests/s, 7983.9438 assertions/s.

1) Skipped:
testcompletionencoding(TestReadline) [/builddir/build/BUILD/ruby-2.0.0-r37735/test/readline/test_readline.rb:294]:
missing test for locale US-ASCII

2) Skipped:
testinputmetacharmultibyte(TestReadline) [/builddir/build/BUILD/ruby-2.0.0-r37735/test/readline/testreadline.rb:418]:
this test needs UTF-8 locale

3) Skipped:
testinlinemethodcache(TestRefinement) [/builddir/build/BUILD/ruby-2.0.0-r37735/test/ruby/testrefinement.rb:729]:
can't implement efficiently with the current implementation of refinements

11387 tests, 2955912 assertions, 0 failures, 0 errors, 31 skips

ruby -v: ruby 2.0.0dev (2012-11-19 trunk 37735) [x86_64-linux]

$ echo $?
130

=end

History

#1 Updated by Vit Ondruch over 1 year ago

  • Status changed from Open to Rejected

Weird. I was able to build r37773 without issues. Closing this issue. Hopefully, that was just some flux.

Also available in: Atom PDF