Bug #7428

Segmentation Fault generated by library1.8.so.1.8.7 on Ubuntu 11.04,

Added by Anthony Generette over 1 year ago. Updated over 1 year ago.

[ruby-core:50041]
Status:Closed
Priority:Normal
Assignee:-
Category:-
Target version:Ruby 1.8.7
ruby -v:ruby 1.8.7 (2012-10-12 patchlevel 371) [i686-linux]

Description

I am new to so many things: Linux, Ruby, bugs.ruby-lang,

'Not sure if anyone here will be able to help, but I'm having trouble with a set of scripts erroring out with a Segmentation fault. Anyone who can lend me a bit of help on this issue, I would really like to hear from. I'm marking this issue as urgent because a business-critical process in the company that I work for is being blocked by it.

It seems that library.1.8.so.1.8.7 is in some sense the source of my trouble, but I'm not sure how to determine:
1.) which precise line is causing the errors.
2.) what steps (package re-installation, etc.) to take to correct the problem.

I'm new enough to Ruby that I don't know whether or not there's a way to run the script(s) in some sort of debugging mode, but if I could figure that out, it might help.

Let me know, if I need to post more information, but here's a bit of info. on the host that I've been running the script from:

ruby -v

ruby 1.8.7 (2012-10-12 patchlevel 371) [i686-linux]
~#

lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.2 LTS
Release: 10.04
Codename: lucid
#

dpkg -l | grep ruby

ii libdbd-pg-ruby 0.3.9-1 Ruby/DBI PostgreSQL driver
ii libdbd-pg-ruby1.8 0.3.9-1 Ruby/DBI PostgreSQL driver for Ruby 1.8
ii libdbi-ruby1.8 0.4.3-2 Database Independent Interface for Ruby 1.8
ii libdbm-ruby1.8 1.8.7.249-2 DBM interface for Ruby 1.8
ii libdeprecated-ruby1.8 2.0.1-2 Library for handling deprecated code in Ruby
ii libopenssl-ruby 4.2 OpenSSL interface for Ruby
ii libopenssl-ruby1.8 1.8.7.249-2 OpenSSL interface for Ruby 1.8
ii libpgsql-ruby1.8 0.8.0-1.1 PostgreSQL interface for Ruby 1.8
ii libruby1.8 1.8.7.249-2 Libraries necessary to run Ruby 1.8
ii ruby 4.2 An interpreter of object-oriented scripting
ii ruby-dev 4.2 Header files for compiling extension modules
ii ruby1.8 1.8.7.249-2 Interpreter of object-oriented scripting lan
ii ruby1.8-dev 1.8.7.249-2 Header files for compiling extension modules
rc rubygems1.8 1.3.5-1ubuntu2 package management framework for Ruby librar
#

#tail /var/log/kern.log
...
Nov 23 08:44:01 sf01-dev01 kernel: [31700171.377711] ruby[5907]: segfault at f4e82404 ip b773ca27 sp bff6a630 error 7 in libruby1.8.so.1.8.7.OLD[b7719000+ce000]

History

#1 Updated by Eric Hodel over 1 year ago

  • Category deleted (lib)
  • Status changed from Open to Closed
  • Priority changed from Urgent to Normal

Please do not set Priority. Your priority and our priority may be different, so please respect ours.

http://www.ruby-lang.org/en/news/2011/10/06/plans-for-1-8-7/ says "We continue to provide normal maintenance for 1.8.7 as usual, until June 2012. ... After that we stop bugfixes.". Since it is "after June 2012" we must close this.

If you can reproduce this on ruby 1.9.3 or newer please open a new ticket.

If you would like to diagnose and fix this yourself compiling a debugging version of ruby 1.8.7 and running it under the debugger may help.

Also available in: Atom PDF