Bug #7569

siphash.c / endian.h

Added by Tuples Arefun over 1 year ago. Updated over 1 year ago.

[ruby-core:50916]
Status:Closed
Priority:Normal
Assignee:-
Category:build
Target version:1.9.3
ruby -v:ruby-1.9.3-p327 Backport:

Description

siphash.c includes endian.h, but on Solaris, there is no such file. BYTE_ORDER also does not exist.

There needs to be a different solution.

This makes it impossible to compile ruby.

SunOS abc.local 5.11 joyent_20120912T055050Z i86pc i386 i86pc Solaris


Related issues

Duplicates Backport93 - Backport #7347: 1.9.3p327 Build fails on Solaris 10 SPARC due to missing ... Closed 11/13/2012
Duplicates Backport93 - Backport #7470: ruby 1.9.3-p327 compile failure in siphash.c on Solaris b... Closed 11/29/2012

History

#1 Updated by Naohisa Goto over 1 year ago

  • Status changed from Open to Feedback

It seems it is the same as #7470. Please try the following solution.

In [Backport93 - Backport #7470], usa (Usaku NAKAMURA) wrote:
It's already fixed on the repository, but not released yet.
Check out r37593 or later from ruby19_3 branch, or simply patch the revision by hand, please.

IMO the simplest way is downloading random.c of the revision and replace the file in p327 package.

Resource:
http://svn.ruby-lang.org/repos/ruby/branches/ruby_1_9_3/random.c

#2 Updated by Tuples Arefun over 1 year ago

You are right, and I should have searched more thoroughly.

#3 Updated by Naohisa Goto over 1 year ago

  • Status changed from Feedback to Closed

This issue is marked as duplicate of #7347 and #7470.
If you find Solaris 11 and/or Solaris x86 specific problems, please submit another report.

Also available in: Atom PDF