Project

General

Profile

Bug #8845

Timeout::ExitException が意図せずに rescue される事がある

Added by takiuchi (Genki Takiuchi) over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
2.0.0
[ruby-core:56906]

Description

timeout.rb の実装が内部的に利用している Timeout::ExitException の無名派生クラスが、
意図しないタイミングで rescue され、timeout処理が実行されないケースがある。
以下の例では、Timeout::Error が発生しない。

timeout 1 do
begin
sleep 10
rescue Exception
end
end


Related issues

Is duplicate of Ruby trunk - Bug #8730: "rescue Exception" rescues Timeout::ExitExceptionRejected2013-08-04

History

#1 [ruby-core:56907] Updated by sorah (Sorah Fukumori) over 4 years ago

  • Status changed from Open to Rejected

https://bugs.ruby-lang.org/issues/8730 と重複しているように思えます

#2 [ruby-core:56909] Updated by sorah (Sorah Fukumori) over 4 years ago

  • Status changed from Rejected to Open

おおっと、ごめんなさい。勘違いだったようです…

#3 [ruby-core:56940] Updated by takiuchi (Genki Takiuchi) over 4 years ago

すみません、重複ですね。
自分で削除する権限が無いので、削除いただけるとありがたいです。

#4 [ruby-core:56941] Updated by sorah (Sorah Fukumori) over 4 years ago

  • Status changed from Open to Rejected

削除はできないので、閉じますね。
(勘違いの勘違いか…)

Also available in: Atom PDF