Project

General

Profile

Actions

Bug #902

closed

1.9.1 preview 1 does not build on mac OSX 10.5.5

Added by erkki (erik scheirer) over 12 years ago. Updated almost 10 years ago.

Status:
Rejected
Priority:
Normal
ruby -v:
Backport:
[ruby-core:20615]

Description

=begin
I downloaded the tarball from uby-lang.org, untarred and ran ./configure, which succeeded.

I am of the opinion that things should 'work out of the box' on each platform, with just ./configure, make, and sudo make install required to build and install.

Running make reveals problems with readline.c :

gcc -I. -I../../.ext/include/i386-darwin9.5.0 -I../.././include -I../.././ext/readline -DRUBY_EXTCONF_H=\"extconf.h\" -D_XOPEN_SOURCE -D_DARWIN_C_SOURCE -fno-common -O2 -g -Wall -Wno-parentheses -pipe -fno-common -o readline.o -c readline.c
readline.c: In function ‘filename_completion_proc_call’:
readline.c:1131: warning: implicit declaration of function ‘completion_matches’
readline.c:1132: error: ‘filename_completion_function’ undeclared (first use in this function)
readline.c:1132: error: (Each undeclared identifier is reported only once
readline.c:1132: error: for each function it appears in.)
readline.c:1132: warning: assignment makes pointer from integer without a cast
readline.c: In function ‘username_completion_proc_call’:
readline.c:1157: error: ‘username_completion_function’ undeclared (first use in this function)
readline.c:1157: warning: assignment makes pointer from integer without a cast
make[1]: *** [readline.o] Error 1
make: *** [exts] Error 1
=end

Actions #1

Updated by yugui (Yuki Sonoda) over 12 years ago

  • Category set to ext
  • Assignee set to kouji (Kouji Takao)
  • Target version set to 1.9.1 Release Candidate

=begin

=end

Actions #2

Updated by yugui (Yuki Sonoda) over 12 years ago

  • Due date set to 12/24/2008
  • Priority changed from Normal to 5

=begin

=end

Actions #3

Updated by kouji (Kouji Takao) over 12 years ago

  • Status changed from Open to Assigned

=begin
I am working.
=end

Actions #4

Updated by kouji (Kouji Takao) over 12 years ago

=begin
Hi erik scheirer.

I tried to check the reported problem. But I did not reproduce it.
Please report your environment and more information for this problem.

My environment:

OS: Mac OSX 10.5.5

Mac ID: MacBook3,1

Xcode:
Version: 3.1.1
Xcode IDE: 1115.0
Xcode Core: 1114.0
ToolSupport: 1102.0

readline:
/usr/include/readline/readline.h -> ../editline/readline.h
/usr/include/editline/readline.h
/* $NetBSD: readline.h,v 1.18 2006/08/21 12:45:30 christos Exp $ */
... snip ...
char *filename_completion_function(const char *, int);
char *username_completion_function(const char *, int);

Thanks, Kouji.

=end

Actions #5

Updated by yugui (Yuki Sonoda) over 12 years ago

  • Priority changed from 5 to 3

=begin

=end

Actions #6

Updated by yugui (Yuki Sonoda) over 12 years ago

  • Status changed from Assigned to Rejected

=begin
can't reproduce.
=end

Actions

Also available in: Atom PDF