Backport #9182

Please backport r43923

Added by Hidetoshi Nagai over 1 year ago. Updated about 1 year ago.

[ruby-dev:47833]
Status:Closed
Priority:Normal
Assignee:-

Description

Please backport r43923 to fix bugs on Ruby/Tk.

Associated revisions

Revision 44336
Added by Usaku NAKAMURA about 1 year ago

merge revision(s) 43923,43925: [Backport #9182]

* ext/tk/lib/tkextlib/tktable/tktable.rb: fix bug on arguments for Proc object.

* ext/tk/sample/scrollframe.rb: forgot a Module definition.

* ext/tk/extconf.rb: check unsupported version of tclConfig.sh/tkConfig.sh. It is because current Ruby/Tk doesn't support Tcl/Tk8.6.

* ext/tk/extconf.rb: change search step of Tcl/Tk libraries.

* ext/tk/lib/tk/namespace.rb: instance_exec() cannot accept a script string.

* ext/tk/lib/tk/msgcat.rb: bug fix on treating encodings. Now, ext/tk/sample/tkmsgcat-load_rb*.rb will work.

History

#1 Updated by Hidetoshi Nagai over 1 year ago

Please backport r43925, too.

#2 Updated by Usaku NAKAMURA about 1 year ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

This issue was solved with changeset r44336.
Hidetoshi, thank you for reporting this issue.
Your contribution to Ruby is greatly appreciated.
May Ruby be with you.


merge revision(s) 43923,43925: [Backport #9182]

* ext/tk/lib/tkextlib/tktable/tktable.rb: fix bug on arguments for Proc object.

* ext/tk/sample/scrollframe.rb: forgot a Module definition.

* ext/tk/extconf.rb: check unsupported version of tclConfig.sh/tkConfig.sh. It is because current Ruby/Tk doesn't support Tcl/Tk8.6.

* ext/tk/extconf.rb: change search step of Tcl/Tk libraries.

* ext/tk/lib/tk/namespace.rb: instance_exec() cannot accept a script string.

* ext/tk/lib/tk/msgcat.rb: bug fix on treating encodings. Now, ext/tk/sample/tkmsgcat-load_rb*.rb will work.

Also available in: Atom PDF