Project

General

Profile

Backport #9284

Exception message of Errno::ENOENT contains strings

Added by abotalov (Andrei Botalov) over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-

Description

Exception message of Errno::ENOENT exception contains strings "@ rb_sysopen" or "@ dir_initialize". It doesn't contain them in Ruby 2.0. I would expect exception message not to contain those strings.

Example:
$ irb

2.1.0dev :001 > File.new('/path/to/not/existent/file')
Errno::ENOENT: No such file or directory @ rb_sysopen - /path/to/not/existent/file
from (irb):1:in initialize'
from (irb):1:in
new'
from (irb):1
from /home/andrey/.rvm/rubies/ruby-2.1.0-rc1/bin/irb:11:in <main>'
2.1.0dev :002 > Dir.open('/path/to/not/existent/folder')
Errno::ENOENT: No such file or directory @ dir_initialize - /path/to/not/existent/folder
from (irb):2:in
open'
from (irb):2
from /home/andrey/.rvm/rubies/ruby-2.1.0-rc1/bin/irb:11:in `'
2.1.0dev :003 >

Version: ruby 2.1.0dev (2013-12-20 trunk 44301) [x86_64-linux]
It's installed via RVM.
Ubuntu 13.04


Related issues

Is duplicate of Ruby master - Bug #9285: Exception message of Errno::ENOENT contains strings @ rb_sysopen and @ dir_initialize in Ruby 2.1RejectedActions

History

#1

Updated by abotalov (Andrei Botalov) over 5 years ago

Sorry for reporting it to Backport instead of ruby-trunk.
I reported it to ruby-trunk as https://bugs.ruby-lang.org/issues/9285 now.

Updated by naruse (Yui NARUSE) over 5 years ago

  • Status changed from Open to Rejected
  • ruby -v set to -

Also available in: Atom PDF