Project

General

Profile

Feature #12141

Updated by nobu (Nobuyoshi Nakada) over 5 years ago

Hi guys ! 

 We have this concept of sending messages to objects with `Object#send`, Object#send, and that's fine, but often a child class defines its own send method, so that's why we have this ugly `Object#__send__` Object#__send__ hack. 

 So, I suggest dropping `Object#__send__` Object#__send__ and aliasing `Object#send` Object#send to `Object#invoke` Object#invoke instead, which seems to me as a better evocative method name. 

 Good or bad idea ? 

 Thanks !

Back