## Background In my understanding, MJIT is a codename like YARV which many people outside Ruby community are not familiar with, so I've used JIT in NEWS or release notes to avoid explaining the "M" part whenever we release a new version. However, because we have the name "MJIT" in one of our constants, we've had some naming inconsistency. For instance, --jit is not --mjit and it's not consistent. ## Proposal Have the same constant as `RubyVM::JIT`, `RubyVM::JIT` and deprecate `RubyVM::MJIT` from Ruby 3.1, and remove the old one in Ruby 3.2. 3.1.