shevegen (Robert A. Heiler)




10:57 PM Ruby trunk Feature #14787: Show documents when completion
I am fine with the suggestion.
If possible, a configuration option for IRB would be nice for people
to decide on ...


01:18 PM Ruby trunk Feature #14783: String#chars_at / String#bytes_at
Is the frequency of #bytes_at common? I understand the use case
stated by Stefan (extract multiple indices via one m...


08:50 PM Ruby trunk Feature #14785: Parse guard statements like regular conditionals
Interesting. I personally very rarely do assignment of variables
followed by if-conditionals in my ruby code.
08:44 PM Ruby trunk Feature #14784: One-sided Comparable#clamp
Considering that Ranges allow a ruby hacker to omit the end value,
for infinity/endless, since about ... a month or ...


09:24 PM Ruby trunk Feature #14781: Enumerator#generate
I agree with the proposal and name.
I would like to recommend and suggest you to add it to the next ruby


06:13 PM Ruby trunk Feature #14249: Remove str[match_str]
As Kentaro showed, there are use cases for [], as-in replacement.
It is quite concise so I think it may be useful ...
11:17 AM Ruby trunk Feature #14777: Add Range#offset ?
I personally prefer the name .offset() here over .shift(), mostly because
my brain remembers Array shift. But the na...


11:02 PM Ruby trunk Feature #14423: Enumerator from single object
> Object#generate to avoid confusing name of #enumerate.
I think #generate as name is problematic too. We may expe...
10:44 PM Ruby trunk Feature #14724: chains of inequalities
Here is the link to the discussion at the developer meeting or rather the
log written:
10:26 PM Ruby trunk Misc #14698: DevelopersMeeting20180517Japan
Thanks for the link to the log shyouhei!

Also available in: Atom