Makoto HARADA

Activity

Reported issues: 1

02/14/2013

07:31 AM Ruby trunk Bug #7850: Gem::Dependency.new( Symbol ) is deprecated?
すいません、rubygems自体は別のコードベースなのですね。rubygemsのほうで調べる/報告してみます。
お騒がせいたしました・・・
05:30 AM Ruby trunk Bug #7850 (Third Party's Issue): Gem::Dependency.new( Symbol ) is deprecated?
Gem::Dependency.new の第一引数が Symbol だった場合、1.9だと問題ありませんが2.0だと例外が投げられます。
これは、想定された非互換でしょうか?
以下が再現コードです。
$ ruby2.0 ...

Also available in: Atom