Bug #7850

Gem::Dependency.new( Symbol ) is deprecated?

Added by Makoto HARADA about 1 year ago. Updated about 1 year ago.

[ruby-dev:46980]
Status:Third Party's Issue
Priority:Normal
Assignee:-
Category:lib
Target version:2.0.0
ruby -v:ruby 2.0.0dev (2013-02-08 trunk 39161) [x86_64-darwin12.2.0] Backport:

Description

Gem::Dependency.new の第一引数が Symbol だった場合、1.9だと問題ありませんが2.0だと例外が投げられます。
これは、想定された非互換でしょうか?

以下が再現コードです。

$ ruby2.0 -v -e 'Gem::Dependency.new(:hoge)'
ruby 2.0.0dev (2013-02-08 trunk 39161) [x86_64-darwin12.2.0]
/***/2.0.0-rc2/lib/ruby/2.0.0/rubygems/dependency.rb:45:in initialize': dependency name must be a String, was :hoge (ArgumentError)
from -e:1:in
new'
from -e:1:in `'

$ ruby1.9 -v -e 'Gem::Dependency.new(:hoge)'
ruby 1.9.3p385 (2013-02-06 revision 39114) [x86_64-darwin12.2.0]

具体的には、Hoe ( Hoe.plugin ) がこの非互換を踏んでいてひっかかりました。

History

#1 Updated by Makoto HARADA about 1 year ago

すいません、rubygems自体は別のコードベースなのですね。rubygemsのほうで調べる/報告してみます。
お騒がせいたしました・・・

#2 Updated by Koichi Sasada about 1 year ago

  • Status changed from Open to Third Party's Issue

3rd party かわからなかったのですが、とりあえずこれで閉じておきます。

#3 Updated by Tomoyuki Chikanaga about 1 year ago

ご報告ありがとうございます。
確かに RubyGems は github にリポジトリがあるのでそちらで報告したほうが早いかもしれません。
もう報告されましたか?
実際に困る gem があるのであれば、何かしらの対応をしたほうが良いのではないかと思います。利用側で対処するという結論になる可能性もありますけど。

Also available in: Atom PDF