Andrew Vit

  • Email: andrew@avit.ca
  • Registered on: 09/28/2013
  • Last connection: 07/27/2015

Activity

Reported issues: 4

05/01/2015

11:02 PM Ruby trunk Bug #11113: Time ranges cannot be used in case statements in 1.9+ but they could in 1.8.7
Good point, it looks like Float is already "covered" (I didn't check) so it's only Time that is the issue here.
> ...
10:48 PM Ruby trunk Bug #11113: Time ranges cannot be used in case statements in 1.9+ but they could in 1.8.7
The "can't iterate" error is simply because Time is float-based: there is no `succ` number.
Something like this co...

10/23/2014

12:24 AM Ruby trunk Feature #10394: An instance method on Enumerator that evaluates the block under with self being t...
It might be confusing if such a thing only exists for Enumerator blocks and nothing else.
~~~ruby
["foo", "bar"]....

10/14/2014

10:46 PM Ruby trunk Bug #10387 (Open): Overwriting an array variable doesn't release referenced objects
I narrowed down the following, but I'm not sure if the problem is mine or a bug:
~~~ruby
require 'objspace'
GC.s...

10/08/2014

07:11 AM Ruby trunk Feature #7793: New methods on Hash
> the block for these methods should take a hash rather than an array.
Do you mean the input should be a single ar...

10/02/2014

07:03 PM Ruby trunk Misc #10312: Give people more control over how the ruby parser sees code and lexical code element...
That sounds like heredoc syntax, which ruby already does.

09/30/2014

11:21 PM Ruby trunk Feature #10308: Pipes in Ruby
Related: #10095

09/26/2014

04:33 PM Ruby trunk Feature #10095: Object#as
This feature also looks a lot like a pipeline.
Here are some examples how people implemented that before, either u...

09/19/2014

06:58 PM Ruby trunk Feature #10254: Array#each and Array#map for nested arrays
`nested_map` makes sense since there is a `flat_map`. This is similar but different:
~~~
[[[1, 2], [3, 4]], [[5, ...
06:01 PM Ruby trunk Feature #10177: Hash#has_key? and Hash#has_value? should be deprecated
+1 for `has_key?` from me.
It's more readable as natural English as pointed out earlier.
`has_key?` is more cle...

Also available in: Atom