Project

General

Profile

Bug #10196

rdoc should not depend on gems

Added by luizluca (Luiz Angelo Daros de Luca) almost 6 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.1.2p95 (2014-05-08 revision 45877) [i486-linux-gnu]
[ruby-core:64715]

Description

Hello,

It seems in rdoc code that it can run without gems.

However, at some places, it explicitly cites gem or Gem without dealing with
the exception. Also, it requires "rubygems", which might be useless since
gem_prelude does that.

I created a patch to remove the extra 'require "rubygems"' and treat the gem "xxx"
exception just like /usr/bin/rdoc does


Files

001-rdoc-remove_gems_dep.patch (908 Bytes) 001-rdoc-remove_gems_dep.patch luizluca (Luiz Angelo Daros de Luca), 09/02/2014 08:26 PM

Updated by luizluca (Luiz Angelo Daros de Luca) over 5 years ago

I sent a PR for rdoc/rdoc in github. Probably
it is the right place to ask for changes in rdoc.

https://github.com/rdoc/rdoc/pull/340

Updated by luizluca (Luiz Angelo Daros de Luca) over 4 years ago

Pull Request accepted. Please, close.

Updated by hsbt (Hiroshi SHIBATA) over 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF