Project

General

Profile

Backport #10243

segmentation fail during a debug session with pry

Added by komidore64 (Adam Price) about 5 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
[ruby-core:65048]

Files

ruby-segfault.txt (427 KB) ruby-segfault.txt komidore64 (Adam Price), 09/15/2014 02:35 PM
rails-segfault-bundle-list.txt (4.59 KB) rails-segfault-bundle-list.txt komidore64 (Adam Price), 09/15/2014 02:35 PM

History

Updated by usa (Usaku NAKAMURA) about 5 years ago

Unfortunately, the necessary information is lacking this log. (It is not your fault.)
This is not a problem of ruby itself, in my intuition.

Can you always reproduce this problem?
And, can you make a small code to reproduce this?

Updated by usa (Usaku NAKAMURA) about 5 years ago

  • Status changed from Open to Feedback

I forgot to say an important thing.
We have already ended the normal bug fix phase of the mentenance of ruby 1.9.3.
This means that if we find the cause of the SEGV, we will not release the fix for 1.9.3.
You should try to update ruby to 2.1 or 2.0.0.

#3

Updated by jeremyevans0 (Jeremy Evans) 3 months ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF