Project

General

Profile

Bug #10695

Segmentation fault with *args and **kwargs

Added by tb (Tobias B├╝hlmann) almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
ruby 2.2.0p0 (2014-12-25 revision 49005) [x86_64-linux]
[ruby-core:67328]

Description

The following will raise a Segmentation fault:

def foo(*args, **kwargs)
  puts "args: #{args}"
  puts "kwargs: #{kwargs}"
end

foo('foo' => 'bar')

Segmentation fault in here.


Related issues

Is duplicate of Ruby master - Bug #10685: Segfault from keyword rest arg when coercing an object that defines to_hash Closed12/31/2014Actions

History

Updated by nobu (Nobuyoshi Nakada) almost 5 years ago

  • Is duplicate of Bug #10685: Segfault from keyword rest arg when coercing an object that defines to_hash added

Updated by nobu (Nobuyoshi Nakada) almost 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF