Project

General

Profile

Actions

Bug #10846

closed

Stack consistency error

Added by jlecour (Jérémy Lecour) about 6 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.2.0p0 (2014-12-25 revision 49005) [x86_64-darwin14]
[ruby-core:68089]

Description

Hi,

I'm maintaining a (private) Rails 4 app, which was running fine on Ruby 2.1.4 and have some issues on 2.2.0

The issue is present on OS X 10.10.2 "ruby 2.2.0p0 (2014-12-25 revision 49005) [x86_64-darwin14]"
but not on a Linux Debian 7 "ruby 2.2.0p0 (2014-12-25 revision 49005) [x86_64-linux]"

In al cases (OS and Ruby version), the code base is the same, the gems used are the same, … only the Ruby version changes.

A rake task is always crashing with 2.2.0 and never crashed with 2.1.4

I've attached 2 files : a console trace, and a crash report.

I have no idea what additional information I could give to help determine if it's a bug in Ruby or else.


Files

diagnostic-reports.txt (94.9 KB) diagnostic-reports.txt jlecour (Jérémy Lecour), 02/11/2015 04:31 PM
trace-console.txt (437 KB) trace-console.txt jlecour (Jérémy Lecour), 02/11/2015 04:31 PM

Updated by nobu (Nobuyoshi Nakada) about 6 years ago

This seems very suspicious.

Thread 23:
0   libsystem_kernel.dylib          0x00007fff89c0e136 __psynch_cvwait + 10
1   ffi_c.bundle                    0x00000001104282db async_cb_wait + 91
2   ruby                            0x000000010e54c5e2 rb_thread_call_without_gvl + 98
3   ffi_c.bundle                    0x0000000110428253 async_cb_event + 99
Actions #2

Updated by jeremyevans0 (Jeremy Evans) over 1 year ago

  • Status changed from Open to Closed
Actions

Also available in: Atom PDF