Project

General

Profile

Bug #11133

Wrong Hyperlink representation in man page

Added by vo.x (Vit Ondruch) over 5 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
ruby -v:
ruby 2.1.6p336 (2015-04-13 revision 50298) [x86_64-linux]
[ruby-core:69122]

Description

There was pointed out recently, that Ruby's man pages are not represented correctly in gnome-terminal [1]. But as per discussion with Gnome folks [2], it might be more widespread then just gnome-terminal [2]. Would you mind to revert r39640 (or fix by other means) to improve the user experience?

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1218871
[2] https://bugzilla.gnome.org/show_bug.cgi?id=749008

Updated by vo.x (Vit Ondruch) over 4 years ago

Although Gnome Terminal was fixed, the Ruby's man page are still rather unique according to [1]. Would you consider to use more common man pages formatting?

[1] https://bugzilla.gnome.org/show_bug.cgi?id=749008#c5

Updated by knu (Akinori MUSHA) about 4 years ago

  • Status changed from Open to Feedback

Sorry for the delay, and thanks for spotting it.

I've replaced the use of the Pa macro with Lk in r56211. The Lk macro was added to mdocml a long time ago, which I didn't notice when I committed r39640.

As for the original problem in URL detection, is there any update on the gnome-terminal side?

Updated by vo.x (Vit Ondruch) about 4 years ago

Akinori MUSHA wrote:

Sorry for the delay, and thanks for spotting it.

I've replaced the use of the Pa macro with Lk in r56211. The Lk macro was added to mdocml a long time ago, which I didn't notice when I committed r39640.

As for the original problem in URL detection, is there any update on the gnome-terminal side?

Yes, it should be fixed, there was this [1] ticket referenced in the original gnome-terminal bug [2]. Testing on Fedora Rawhide with:

$ rpm -q gnome-terminal
gnome-terminal-3.21.90-2.fc26.x86_64

The URLs in man pages of Ruby 2.3.1 are recognized correctly. Testing also with r56256, the URLs are recognized correctly as well, although they are bold now (if this was intentional).

[1] https://bugzilla.gnome.org/show_bug.cgi?id=756038
[2] https://bugzilla.gnome.org/show_bug.cgi?id=749008#c7

Updated by knu (Akinori MUSHA) about 4 years ago

  • Status changed from Feedback to Closed

Thanks for your confirmation! It's just as intended that the URLs being rendered in bold.

Also available in: Atom PDF