Project

General

Profile

Bug #11403

Segmentation fault when running Rails Server

Added by hussain.md1@tcs.com (Athar Hussain) about 4 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.2.2p95 (2015-04-13 revision 50295) [x86_64-darwin14]
[ruby-core:70163]

Description

I have newly installed ruby and rails in my new MAC 10.10

But when I am trying to run am rails application its showing this segmentation fault

qaz admin$ rails server
Warning: Running `gem pristine --all` to regenerate your installed gemspecs (and deleting then reinstalling your bundle if you use bundle --path) will improve the startup performance of Spring.
* /Users/admin/.rvm/gems/ruby-2.2.1/gems/json-1.8.3/lib/json/ext/parser.bundle: ***[BUG] Segmentation fault at 0x00000000000418***

Abort trap: 6

Files

bug-11403.log (38.9 KB) bug-11403.log nobu (Nobuyoshi Nakada), 07/29/2015 06:42 AM

History

Updated by cesario (Franck Verrot) about 4 years ago

  • Assignee deleted (hussain.md1@tcs.com (Athar Hussain))

Athar Hussain wrote:

I have newly installed ruby and rails in my new MAC 10.10

But when I am trying to run am rails application its showing this segmentation fault

qaz admin$ rails server
Warning: Running `gem pristine --all` to regenerate your installed gemspecs (and deleting then reinstalling your bundle if you use bundle --path) will improve the startup performance of Spring.
* /Users/admin/.rvm/gems/ruby-2.2.1/gems/json-1.8.3/lib/json/ext/parser.bundle: ***[BUG] Segmentation fault at 0x00000000000418***
ruby 2.2.2p95 (2015-04-13 revision 50295) [x86_64-darwin14]

Hi Athar,

For some reason you have a setup that is using RVM on 2.2.1 and rbenv on 2.2.2. You might want to drop one of them and reinstall your gems.

HTH.

Updated by nobu (Nobuyoshi Nakada) about 4 years ago

Also available in: Atom PDF