Project

General

Profile

Bug #1142

/opt/ruby19/lib/ruby19/1.9.1/openssl/ssl.rb:31: [BUG] Bus Error

Added by ricard (Ricard Forniol Agustí) over 10 years ago. Updated about 8 years ago.

Status:
Rejected
Priority:
Normal
Target version:
ruby -v:
ruby 1.9.1p0 (2009-01-30 revision 21907) [i386-darwin9.6.0]
Backport:
[ruby-core:21989]

Description

=begin
After executing ruby19 test.rb of the project: git://rubyforge.org/dram.git

I don't know if it's the same as bug "Bug #1080".
/opt/ruby19/lib/ruby19/1.9.1/openssl/ssl.rb:31: [BUG] Bus Error
ruby 1.9.1p0 (2009-01-30 revision 21907) [i386-darwin9.6.0]

-- control frame ----------
c:0023 p:---- s:0057 b:0057 l:000056 d:000056 CFUNC :initialize
c:0022 p:---- s:0055 b:0055 l:000054 d:000054 CFUNC :new
c:0021 p:0063 s:0052 b:0052 l:000051 d:000051 CLASS /opt/ruby19/lib/ruby19/1.9.1/openssl/ssl.rb:31
c:0020 p:0011 s:0050 b:0050 l:000049 d:000049 CLASS /opt/ruby19/lib/ruby19/1.9.1/openssl/ssl.rb:23
c:0019 p:0011 s:0048 b:0048 l:000047 d:000047 CLASS /opt/ruby19/lib/ruby19/1.9.1/openssl/ssl.rb:22
c:0018 p:0045 s:0046 b:0046 l:000045 d:000045 TOP /opt/ruby19/lib/ruby19/1.9.1/openssl/ssl.rb:21
c:0017 p:---- s:0044 b:0044 l:000043 d:000043 FINISH
c:0016 p:---- s:0042 b:0042 l:000041 d:000041 CFUNC :require
c:0015 p:0059 s:0038 b:0038 l:000037 d:000037 TOP /opt/ruby19/lib/ruby19/1.9.1/openssl.rb:22
c:0014 p:---- s:0036 b:0036 l:000035 d:000035 FINISH
c:0013 p:---- s:0034 b:0034 l:000033 d:000033 CFUNC :require
c:0012 p:0049 s:0030 b:0030 l:000029 d:000029 TOP /opt/ruby19/lib/ruby19/1.9.1/net/smtp.rb:26
c:0011 p:---- s:0028 b:0028 l:000027 d:000027 FINISH
c:0010 p:---- s:0026 b:0026 l:000025 d:000025 CFUNC :require
c:0009 p:0012 s:0022 b:0022 l:000013 d:000021 BLOCK /Users/ricard/dram/lib/dram.rb:3
c:0008 p:---- s:0019 b:0019 l:000018 d:000018 FINISH
c:0007 p:---- s:0017 b:0017 l:000016 d:000016 CFUNC :each
c:0006 p:0062 s:0014 b:0014 l:000013 d:000013 TOP /Users/ricard/dram/lib/dram.rb:3
c:0005 p:---- s:0012 b:0012 l:000011 d:000011 FINISH
c:0004 p:---- s:0010 b:0010 l:000009 d:000009 CFUNC :require
c:0003 p:0011 s:0006 b:0006 l:002624 d:0016f4 EVAL test.rb:1
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:002624 d:002624 TOP :38964


-- Ruby level backtrace information-----------------------------------------
/opt/ruby19/lib/ruby19/1.9.1/openssl/ssl.rb:31:in initialize'
/opt/ruby19/lib/ruby19/1.9.1/openssl/ssl.rb:31:in
new'
/opt/ruby19/lib/ruby19/1.9.1/openssl/ssl.rb:31:in <class:SSLContext>'
/opt/ruby19/lib/ruby19/1.9.1/openssl/ssl.rb:23:in
module:SSL'
/opt/ruby19/lib/ruby19/1.9.1/openssl/ssl.rb:22:in <module:OpenSSL>'
/opt/ruby19/lib/ruby19/1.9.1/openssl/ssl.rb:21:in
'
/opt/ruby19/lib/ruby19/1.9.1/openssl.rb:22:in require'
/opt/ruby19/lib/ruby19/1.9.1/openssl.rb:22:in
'
/opt/ruby19/lib/ruby19/1.9.1/net/smtp.rb:26:in require'
/opt/ruby19/lib/ruby19/1.9.1/net/smtp.rb:26:in
'
/Users/ricard/dram/lib/dram.rb:3:in require'
/Users/ricard/dram/lib/dram.rb:3:in
block in '
/Users/ricard/dram/lib/dram.rb:3:in each'
/Users/ricard/dram/lib/dram.rb:3:in
'
test.rb:1:in require'
test.rb:1:in
'

-- C level backtrace information -------------------------------------------
0x116012 0 ruby19 0x00116012 rb_vm_bugreport + 82
0x2b76c 1 ruby19 0x0002b76c rb_warning + 444
0x2b7cb 2 ruby19 0x0002b7cb rb_bug + 43
0xbc7cb 3 ruby19 0x000bc7cb rb_enable_interrupt + 75
0x957c92bb 4 libSystem.B.dylib 0x957c92bb _sigtramp + 43
0xffffffff 5 ??? 0xffffffff 0x0 + 4294967295

[NOTE]
You may encounter a bug of Ruby interpreter. Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

Abort trap
=end


Related issues

Related to Backport187 - Feature #405: ssl.rb:31: [BUG] Bus ErrorFeedback08/05/2008Actions
Related to Ruby trunk - Bug #1678: uninitialized value in ossl_x509store_initialize causes occasional segfaultClosed06/23/2009Actions

Associated revisions

Revision c3546c76
Added by hsbt (Hiroshi SHIBATA) over 4 years ago

  • lib/rubygems: Update to RubyGems HEAD(5c3b6f3). Fixed #1156, #1142, #1115, #1142, #1139 on rubygems/rubygems
  • test/rubygems: ditto.

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@49511 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 49511
Added by hsbt (Hiroshi SHIBATA) over 4 years ago

  • lib/rubygems: Update to RubyGems HEAD(5c3b6f3). Fixed #1156, #1142, #1115, #1142, #1139 on rubygems/rubygems
  • test/rubygems: ditto.

Revision 49511
Added by hsbt (Hiroshi SHIBATA) over 4 years ago

  • lib/rubygems: Update to RubyGems HEAD(5c3b6f3). Fixed #1156, #1142, #1115, #1142, #1139 on rubygems/rubygems
  • test/rubygems: ditto.

Revision 49511
Added by hsbt (Hiroshi SHIBATA) over 4 years ago

  • lib/rubygems: Update to RubyGems HEAD(5c3b6f3). Fixed #1156, #1142, #1115, #1142, #1139 on rubygems/rubygems
  • test/rubygems: ditto.

Revision 49511
Added by hsbt (Hiroshi SHIBATA) over 4 years ago

  • lib/rubygems: Update to RubyGems HEAD(5c3b6f3). Fixed #1156, #1142, #1115, #1142, #1139 on rubygems/rubygems
  • test/rubygems: ditto.

Revision 49511
Added by hsbt (Hiroshi SHIBATA) over 4 years ago

  • lib/rubygems: Update to RubyGems HEAD(5c3b6f3). Fixed #1156, #1142, #1115, #1142, #1139 on rubygems/rubygems
  • test/rubygems: ditto.

History

#1

Updated by rick (Rick Lloyd) over 10 years ago

=begin
I was able to trigger the same bus error with ruby-1.9.1p1.

/opt/local/lib/ruby/1.9.1/openssl/ssl.rb:31: [BUG] Bus Error
ruby 1.9.1 (2008-10-28 revision 19983) [powerpc-darwin9.6.0]

-- control frame ----------
c:0059 p:---- s:0221 b:0221 l:000220 d:000220 CFUNC :initialize
c:0058 p:---- s:0219 b:0219 l:000218 d:000218 CFUNC :new
c:0057 p:0063 s:0216 b:0216 l:000215 d:000215 CLASS /opt/local/lib/ruby/1.9.1/openssl/ssl.rb:31
c:0056 p:0011 s:0214 b:0214 l:000213 d:000213 CLASS /opt/local/lib/ruby/1.9.1/openssl/ssl.rb:23
c:0055 p:0011 s:0212 b:0212 l:000211 d:000211 CLASS /opt/local/lib/ruby/1.9.1/openssl/ssl.rb:22
c:0054 p:0045 s:0210 b:0210 l:000209 d:000209 TOP /opt/local/lib/ruby/1.9.1/openssl/ssl.rb:21
c:0053 p:---- s:0208 b:0208 l:000207 d:000207 FINISH :set_encoding
c:0052 p:---- s:0206 b:0206 l:000205 d:000205 CFUNC :require
c:0051 p:0012 s:0202 b:0202 l:000191 d:000201 BLOCK /opt/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.0/lib/active_support/dependencies.rb:156
c:0050 p:0055 s:0200 b:0200 l:000199 d:000199 METHOD /opt/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.0/lib/active_support/dependencies.rb:521
c:0049 p:0041 s:0192 b:0192 l:000191 d:000191 METHOD /opt/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.0/lib/active_support/dependencies.rb:156
c:0048 p:0059 s:0186 b:0186 l:000185 d:000185 TOP /opt/local/lib/ruby/1.9.1/openssl.rb:22
c:0047 p:---- s:0184 b:0184 l:000183 d:000183 FINISH :set_encoding
c:0046 p:---- s:0182 b:0182 l:000181 d:000181 CFUNC :require
c:0045 p:0012 s:0178 b:0178 l:000167 d:000177 BLOCK /opt/local/lib/ruby/gems/1.9.1/gems/activesupport-2.3.0/lib/active_support/dependencies.rb:156
.
.
.

I traced the cause to be running thin (web server) against ruby where thin was linked with libssl.0.9.dylib and ruby with libssl.0.9.8.dylib.

Obvious cockpit error... NOT A RUBY OR THIN BUG.

Rick Lloyd
=end

#2

Updated by marcandre (Marc-Andre Lafortune) over 9 years ago

  • Category set to lib
  • Assignee set to gotoyuzo (GOTOU Yuuzou)

=begin

=end

#3

Updated by mame (Yusuke Endoh) about 9 years ago

  • Status changed from Open to Feedback
  • Assignee changed from gotoyuzo (GOTOU Yuuzou) to mame (Yusuke Endoh)

=begin
Hi, Ricard

2009/2/12 Ricard Forniol Agusti redmine@ruby-lang.org:

After executing ruby19 test.rb of the project: git://rubyforge.org/dram.git

I could not reproduce with trunk on Linux.
Can you still reproduce this?
If so, does the crash occur just by require "openssl"?

2009/2/28 Rick Lloyd redmine@ruby-lang.org:

I traced the cause to be running thin (web server) against ruby where thin was linked with libssl.0.9.dylib and ruby with libssl.0.9.8.dylib.

Obvious cockpit error... NOT A RUBY OR THIN BUG.

Ricard, could you confirm this?

If you don't answer, I'm sorry but I'll close this ticket.

--
Yusuke ENDOH mame@tsg.ne.jp
=end

#4

Updated by mame (Yusuke Endoh) about 9 years ago

  • Priority changed from Normal to 3

=begin

=end

#5

Updated by mame (Yusuke Endoh) about 9 years ago

  • Status changed from Feedback to Rejected

=begin

=end

Also available in: Atom PDF