Project

General

Profile

Bug #11641

ruby(1) manpage shows extraneous space for -F option

Added by rlk (Ryan Koppenhaver) almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.2.3p173 (2015-08-18 revision 51636) [x86_64-linux]
[ruby-core:71283]

Description

The manual page for the ruby executable describes the -F option as:

     -F pattern     Specifies input field separator ($;).

This (and the corresponding item in the synopsis) should be -Fpattern, with no space. The output of ruby --help correctly omits the space.

Demonstration of Ruby's actual behavior:

$ echo 'axb' | ruby -Fx -lane 'p $F'
["a", "b"]
$ echo 'axb' | ruby -F x -lane 'p $F'
ruby: No such file or directory -- x (LoadError)

I have not reproduced this with a build of the latest ruby from svn, but trunk/man/ruby.1 has not been changed since before my version was built.

#1

Updated by nobu (Nobuyoshi Nakada) almost 5 years ago

  • Status changed from Open to Closed

Applied in changeset r52408.


remove extraneous space

  • man/ruby.1 (SYNOPSIS): remove extraneous space for -F option as it does not allow spaces before its argument. [ruby-core:71283] [Bug #11641]

Also available in: Atom PDF