Bug #11765

Trouble using fiddle to call Fortran from C

Added by lxh37 (Liz Huang) over 4 years ago. Updated over 4 years ago.

Third Party's Issue
Target version:
ruby -v:
ruby 2.2.1p85 (2015-02-26 revision 49769) [x86_64-linux]


Hi, I tried to transfer my project from Mac to Linux, but have trouble to use fiddle to call
the dynamic library which I generated using same Fortran and C codes I used in Mac. I used same
version of Ruby both in Mac and Linux. To narrow the cause, I created a simple C program, I
could call it using fiddle, then I tried to create a simple C and Fortran, but couldn't call
it from Ruby On Rails. I posted the codes in Intel Fortran for Linux Forum to make sure
is no bug in my code. I attached error_log, development_log and also Fortran and C code,
hope they are helpful for debug.


development.log (1 KB) development.log lxh37 (Liz Huang), 12/02/2015 08:06 PM
error_log (467 KB) error_log lxh37 (Liz Huang), 12/02/2015 08:06 PM
add.c (1.12 KB) add.c lxh37 (Liz Huang), 12/02/2015 08:11 PM
add.h (261 Bytes) add.h lxh37 (Liz Huang), 12/02/2015 08:11 PM

Also available in: Atom PDF