Project

General

Profile

Actions

Bug #1178

closed

circular dependency on missing ffi

Added by sinobra (Fred Obermann) about 12 years ago. Updated almost 10 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Target version:
ruby -v:
ruby 1.9.1p0 (2009-01-30 revision 21907) [i686-linux]
Backport:
[ruby-core:22260]

Description

=begin
On Linux version 2.6.27.10-desktop-1mnb (qateam@titan.mandriva.com) (gcc version 4.3.2 (GCC) ) #1 SMP Thu Jan 29 10:49:40 EST 2009, I downloaded, configured, made, and installed ruby 1.9.1p0 (2009-01-30 revision 21907) [i686-linux]

I run gem install and I get this:

ERROR: While executing gem ... (NameError)
uninitialized constant Zlib::FFI

Now theoretically I should be able to download and install ffi with 'gem install ffi', but gem is broken without ffi
=end

Actions #1

Updated by nobu (Nobuyoshi Nakada) about 12 years ago

  • Status changed from Open to Feedback

=begin
I couldn't reproduce it, with or without sudo.

$ gem19 install ffi
WARNING: Installing to ~/.gem since /usr/lib/ruby/gems/1.9.1 and
/usr/bin aren't both writable.
WARNING: You don't have /home/nobu/.gem/ruby/1.9.1/bin in your PATH,
gem executables will not run.
Building native extensions. This could take a while...
Successfully installed ffi-0.2.0
1 gem installed
Installing ri documentation for ffi-0.2.0...
Updating class cache with 1311 classes...
Installing RDoc documentation for ffi-0.2.0...

=end

Actions #2

Updated by yugui (Yuki Sonoda) almost 12 years ago

  • Priority changed from 5 to 3

=begin

=end

Actions #3

Updated by yugui (Yuki Sonoda) almost 12 years ago

  • Status changed from Feedback to Rejected

=begin

=end

Actions

Also available in: Atom PDF