Project

General

Profile

Bug #12248

Backport rubygems fix from upstream repo for Ruby 2.2.x

Added by hsbt (Hiroshi SHIBATA) over 3 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Normal
Target version:
-
[ruby-core:74814]

Description

Rubygems fixed bug that was introduced by Rubygems 2.4.5 on Ruby 2.2.0.

This bug is backported 2.4.x branch on rubygems upstream repository.

Please backport attached patch into ruby_2_2 branch.


Files


Related issues

Related to Ruby master - Bug #12579: Backport rubygems fix from upstream repo for Ruby 2.2.x (2)ClosedActions

Associated revisions

Revision 9e799379
Added by usa (Usaku NAKAMURA) over 3 years ago

  • lib/rubygems/core_ext/kernel_require.rb: -I should always win over gems. [ruby-core:74814] [Backport #12248]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_2@55357 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 55357
Added by usa (Usaku NAKAMURA) over 3 years ago

  • lib/rubygems/core_ext/kernel_require.rb: -I should always win over gems. [ruby-core:74814] [Backport #12248]

History

Updated by hsbt (Hiroshi SHIBATA) over 3 years ago

  • Status changed from Open to Closed

Updated by usa (Usaku NAKAMURA) over 3 years ago

  • Backport changed from 2.1: DONTNEED, 2.2: REQUIRED, 2.3: DONTNEED to 2.1: DONTNEED, 2.2: DONE, 2.3: DONTNEED

The patch applied to ruby_2_2 at r55357.

Updated by usa (Usaku NAKAMURA) over 3 years ago

  • Backport changed from 2.1: DONTNEED, 2.2: DONE, 2.3: DONTNEED to 2.1: DONTNEED, 2.2: REQUIRED, 2.3: DONTNEED

... but reverted at r55365 because of test failures.
Please check the patch and retry.

Updated by usa (Usaku NAKAMURA) over 3 years ago

  • Assignee set to hsbt (Hiroshi SHIBATA)

Updated by hsbt (Hiroshi SHIBATA) over 3 years ago

I confirmed that tests of 2.4.x branch on upstream repository are broken now.
I try to fix this on rubygems repository at first.

Thank you for your advice.

Updated by usa (Usaku NAKAMURA) over 3 years ago

Ah, please also confirm about version number of rubygems.
Current version in ruby_2_2 is 2.4.5.1.
The patched version should be 2.4.5.2? or other one?

Updated by usa (Usaku NAKAMURA) about 3 years ago

  • Status changed from Closed to Feedback

Current status?

#8

Updated by usa (Usaku NAKAMURA) about 3 years ago

  • Related to Bug #12579: Backport rubygems fix from upstream repo for Ruby 2.2.x (2) added

Updated by hsbt (Hiroshi SHIBATA) about 3 years ago

rubygems-2.4.x still failed tests on the upstream repository. I have no time for investigating it.

Please backport #12579 before this patch.

Updated by hsbt (Hiroshi SHIBATA) almost 2 years ago

  • Status changed from Feedback to Rejected

This is not a security fix. so It's over the maintenance phase for Ruby 2.2.

Also available in: Atom PDF