Project

General

Profile

Actions

Bug #13155

closed

Segfault testing Pry

Added by vo.x (Vit Ondruch) over 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.4.1p111 (2017-03-22 revision 58053) [powerpc64le-linux]
[ruby-core:79239]

Description

Trying to fix Pry on Fedora Rawhide, I get random segfaults. Unfortunately, I can't see any pattern in them. The backtrace is always different. Attaching two logs in case it might make the issue more obvious. Here are some package versions which might be of interest:

$ rpm -q readline
readline-7.0-4.fc26.x86_64

$ rpm -q glibc
glibc-2.24.90-28.fc26.x86_64


Files

segv1.log (44.2 KB) segv1.log vo.x (Vit Ondruch), 01/24/2017 12:46 PM
segv2.log (44.1 KB) segv2.log vo.x (Vit Ondruch), 01/24/2017 12:46 PM
segv3 (51.6 KB) segv3 vo.x (Vit Ondruch), 06/23/2017 08:46 AM
segv4 (49.3 KB) segv4 vo.x (Vit Ondruch), 06/23/2017 08:46 AM

Related issues 1 (0 open1 closed)

Related to Ruby master - Bug #13605: GC bug calling `ObjectSpace.each_object`ClosedActions

Updated by vo.x (Vit Ondruch) over 5 years ago

This appears to crash on Travis (Ubuntu) as well:

https://travis-ci.org/pry/pry/jobs/183781286

Updated by sorah (Sorah Fukumori) about 5 years ago

  • Status changed from Open to Feedback

I couldn't reproduce with 2.4.1 and trunk. Maybe it got a fix after 2.4.0 release.

Updated by vo.x (Vit Ondruch) about 5 years ago

Will see as soon as 2.4.1 lands in Fedora. Will keep an eye on this.

Updated by vo.x (Vit Ondruch) almost 5 years ago

  • ruby -v changed from ruby 2.4.0p0 (2016-12-24 revision 57164) [x86_64-linux] to ruby 2.4.1p111 (2017-03-22 revision 58053) [powerpc64le-linux]
  • File segv4 segv4 added
  • File segv3 segv3 added

This was triggered again during automatic rebuild of Fedora's Pry package

https://apps.fedoraproject.org/koschei/build/2977931

and it also failed in my subsequent build. See the attached logs. So 2.4.1 is still affected :/

Updated by wanabe (_ wanabe) almost 5 years ago

I guess it is the same issue as #13605 because of the log pattern.
(using pry, T_NONE, newobj_slowpath_wb_protected and gc_mark_children)

Actions #6

Updated by wanabe (_ wanabe) almost 5 years ago

  • Related to Bug #13605: GC bug calling `ObjectSpace.each_object` added

Updated by vo.x (Vit Ondruch) over 4 years ago

  • Status changed from Feedback to Closed

This seems to be fixed by Ruby 2.4.2, because there was no build failure since this version is available in Fedora. So it was probably the same issue as #13605 pointed out by wanabe.

Actions

Also available in: Atom PDF