Project

General

Profile

Bug #13410

[BUG] Segmentation fault at file read

Added by timhormersdorf@googlemail.com (Tim Foerster) over 2 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
[ruby-core:80610]

Description

The following line has triggered this issue:

Dir['/proc/[0-9]*/cmdline'].map do |x|
  File.read(x)[/^qemu-system-x86_64.*(vm-\d+)/,1] # Line 41
end

Files

bug-13410.log (125 KB) bug-13410.log nobu (Nobuyoshi Nakada), 04/07/2017 03:23 PM

History

#1

Updated by timhormersdorf@googlemail.com (Tim Foerster) over 2 years ago

  • Description updated (diff)
#2

Updated by timhormersdorf@googlemail.com (Tim Foerster) over 2 years ago

  • Description updated (diff)

Updated by nobu (Nobuyoshi Nakada) over 2 years ago

2.3.1 is outdated.
Does it happen with 2.3.4 or 2.4.1?

Updated by timhormersdorf@googlemail.com (Tim Foerster) over 2 years ago

I'am currently unable to reproduce them, i hoped any body could take a look at file implementation. I'll get feedback as soon as possible.

Updated by nobu (Nobuyoshi Nakada) over 2 years ago

Try newer versions, not the outdated one.

#6

Updated by jeremyevans0 (Jeremy Evans) 3 months ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF