Project

General

Profile

Bug #13580

bug

Added by bjorn2 (Sergey Homa) about 2 years ago. Updated 23 days ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.4.0p0 (2016-12-24 revision 57164) [x86_64-linux]
[ruby-core:81278]

History

Updated by bjorn2 (Sergey Homa) about 2 years ago

on second run

 ~/projects/ngrx-todolist   with_jsonapi_suite  clear; rspec spec/api/comments/create_spec.rb

  1) comment#create valid
     Failure/Error: let!(:task)    { create :task, task: task }

     SystemStackError:
       stack level too deep
     # ./spec/api/comments/create_spec.rb:5:in `block (2 levels) in <top (required)>'
     # ./spec/api/comments/create_spec.rb:5:in `block (2 levels) in <top (required)>'
     # ./spec/api/comments/create_spec.rb:5:in `block (2 levels) in <top (required)>'
     # ./spec/api/comments/create_spec.rb:5:in `block (2 levels) in <top (required)>'
     # ./spec/api/comments/create_spec.rb:5:in `block (2 levels) in <top (required)>'
     # ./spec/api/comments/create_spec.rb:5:in `block (2 levels) in <top (required)>'
     # ./spec/api/comments/create_spec.rb:5:in `block (2 levels) in <top (required)>'
     # ./spec/api/comments/create_spec.rb:5:in `block (2 levels) in <top (required)>'
     # ./spec/api/comments/create_spec.rb:5:in `block (2 levels) in <top (required)>'

Updated by hsbt (Hiroshi SHIBATA) about 2 years ago

  • Status changed from Open to Feedback

Can you try with Ruby 2.4.1?

And second run is caused by rspec specification. It's not interpreter's bug.

#3

Updated by jeremyevans0 (Jeremy Evans) 23 days ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF