Project

General

Profile

Actions

Bug #13859

closed

Segfault running `Fiber#inspect` on trunk

Added by alexgenco (Alex Genco) almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.5.0dev (2017-09-01 trunk 59716) [x86_64-darwin15]
[ruby-core:82629]

Description

I started encountering segfaults on ruby-head in the test suite for neovim-ruby a couple weeks ago (e.g. https://travis-ci.org/alexgenco/neovim-ruby/jobs/268931902).

After some digging, it looks like the segfaults are being caused by Fiber#inspect. Here's a minimal reproduction:

ruby -r fiber -e "Fiber.current.inspect"

I did a git bisect and it seems to be related to this commit: https://github.com/ruby/ruby/commit/43384ae9788be243746849ee54d9f5c8f7e0412b

Segfault output is attached. Please let me know if you need more information. Thanks!


Files

bug_report.txt (4.27 KB) bug_report.txt alexgenco (Alex Genco), 09/01/2017 10:25 PM
Actions #1

Updated by nobu (Nobuyoshi Nakada) almost 5 years ago

  • Status changed from Open to Closed

Applied in changeset trunk|r59721.


cont.c: fix root fiber to_s

Actions

Also available in: Atom PDF