Project

General

Profile

Bug #14093

REXML doesn't implement name() and interprets nam() as an element path.

Added by jcavalieri (John Cavalieri) almost 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Normal
Target version:
-
ruby -v:
2.4.2
[ruby-core:83702]

Description

Please see the attached script.

Considering this xml:

<a><b><name/></b></a>

The xpath /a/b/name() xpath should return the name of element a. Instead it returns the child element name.

Output:

<name/>

Files

bug_script.rb (371 Bytes) bug_script.rb script to reproduce jcavalieri (John Cavalieri), 11/08/2017 08:03 PM

History

Updated by hsbt (Hiroshi SHIBATA) almost 2 years ago

  • Assignee set to kou (Kouhei Sutou)
  • Status changed from Open to Assigned

Updated by kou (Kouhei Sutou) almost 2 years ago

  • Status changed from Assigned to Rejected

/a/b/name() is an invalid LocationPath. LocationPath is consists of Steps. You can't use name() as Step. Because name() isn't NodeTest.

#3

Updated by kou (Kouhei Sutou) almost 2 years ago

  • Description updated (diff)

Also available in: Atom PDF