Project

General

Profile

Bug #14113

Crashed Thread: 15 thread_pool.rb*

Added by lanakushnir (Lana Kushnir) almost 2 years ago. Updated about 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.4.0p0 (2016-12-24 revision 57164) [x86_64-darwin17]
[ruby-core:83798]

Description

Started a project and it immediately crashed. This happened before, but so instantly.

/Users/vlad/.rbenv/versions/2.4.0/lib/ruby/2.4.0/forwardable.rb:228: [BUG] Segmentation fault at 0x00000000000038
ruby 2.4.0p0 (2016-12-24 revision 57164) [x86_64-darwin17]


Files

ruby_2017-11-16-085207_iMac.crash (51.3 KB) ruby_2017-11-16-085207_iMac.crash lanakushnir (Lana Kushnir), 11/16/2017 02:20 PM

History

Updated by nobu (Nobuyoshi Nakada) almost 2 years ago

  • Status changed from Open to Feedback

2.4.0 is outdated, does it reproduce with 2.4.2, or trunk?

Thread 17 Crashed:: thread_pool.rb*
0   libsystem_kernel.dylib          0x00007fff6b6defce __pthread_kill + 10
1   libsystem_pthread.dylib         0x00007fff6b81c150 pthread_kill + 333
2   libsystem_c.dylib               0x00007fff6b63b30a abort + 127
3   ruby                            0x000000010ad58ef9 die + 9
4   ruby                            0x000000010ad5911e rb_bug_context + 542
5   ruby                            0x000000010ae37f28 sigsegv + 72
6   libsystem_platform.dylib        0x00007fff6b80ff5a _sigtramp + 26

Unfortunately, this just tells that it crashed.
Could you show backtrace at the crash?

Updated by nobu (Nobuyoshi Nakada) almost 2 years ago

Looks like [Bug #13107], which has been fixed in 2.4.1 already.

#3

Updated by jeremyevans0 (Jeremy Evans) about 2 months ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF