Project

General

Profile

Bug #14135

OneDrive folder on windows doesnt behave

Added by huntertim (Tim Hunter) about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
ruby 2.4.2p198 (2017-09-14 revision 59899) [x64-mingw32]
[ruby-core:83923]

Description

basic ruby file commands cause Segmentation fault on OneDrive folder in windows

Create a file or folder in your OneDrive in windows and try to access through ruby.

Simple example is File.file?("#{File.expand_path("~")}/OneDrive/test.txt") but any attempt to access a file or directory causes a Segmentation Fault
see attached for details


Files

onedrivebug.txt (12.6 KB) onedrivebug.txt huntertim (Tim Hunter), 11/28/2017 02:46 PM

Related issues

Is duplicate of Ruby master - Bug #14047: SEGV happen when running script under OneDrive directory if File On-Demand is enabledClosedActions

History

Updated by huntertim (Tim Hunter) about 2 years ago

I compiled a version on windows and this is fixed in
ruby 2.5.0dev (2017-11-28 trunk 60926) [i386-mswin32_140]

Updated by mame (Yusuke Endoh) about 2 years ago

  • Status changed from Open to Closed

huntertim (Tim Hunter) wrote:

I compiled a version on windows and this is fixed in
ruby 2.5.0dev (2017-11-28 trunk 60926) [i386-mswin32_140]

Yes, this issue was fixed in #14047. Please wait a backport release. Thank you anyway.

#3

Updated by usa (Usaku NAKAMURA) about 2 years ago

  • Is duplicate of Bug #14047: SEGV happen when running script under OneDrive directory if File On-Demand is enabled added

Also available in: Atom PDF