Project

General

Profile

Bug #14182

Backport r55265

Added by hsbt (Hiroshi SHIBATA) almost 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
ruby -v:
[ruby-core:84250]

Associated revisions

Revision 55265
Added by nobu (Nobuyoshi Nakada) over 3 years ago

mkmf.rb: sort lists of source and object files

  • lib/mkmf.rb (create_makefile): sort lists of source and object files in generated Makefile, unless given by extconf.rb. [Fix GH-1367]

Without sorting the list of object files explicitely, its order is
indeterministic, because readdir() is also not deterministic.
When the list of object files varies between builds, they are
linked in a different order, which results in an unreproducible
build.

Revision 73549682
Added by usa (Usaku NAKAMURA) over 1 year ago

merge revision(s) 55265: [Backport #14182]
* lib/mkmf.rb (create_makefile): sort lists of source and object
files in generated Makefile, unless given by extconf.rb.
[Fix GH-1367]

git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_2_3@62124 b2dd03c8-39d4-4d8f-98ff-823fe69b080e

Revision 62124
Added by usa (Usaku NAKAMURA) over 1 year ago

merge revision(s) 55265: [Backport #14182]
* lib/mkmf.rb (create_makefile): sort lists of source and object
files in generated Makefile, unless given by extconf.rb.
[Fix GH-1367]

History

Updated by usa (Usaku NAKAMURA) over 1 year ago

  • Backport changed from 2.3: REQUIRED, 2.4: DONTNEED to 2.3: DONE, 2.4: DONTNEED

ruby_2_3 r62124 merged revision(s) 55265.

Also available in: Atom PDF